Cloudflare Outtage Causing Intermittent 502 Bad Gateway Errors

Incident Report for Teachable

Resolved

Cloudflare has resolved the issue resulting in 502 errors impacting parts of the platform. For updates from Cloudflare, please refer to their status page at https://www.cloudflarestatus.com/. As of now, all systems are performing as expected on the Teachable platform. Thank you for your patience and understanding.
Posted Dec 19, 2025 - 14:48 EST

Investigating

Our team has identified an issue with Cloudflare’s service that is resulting in 502 errors impacting parts of the platform. We’re actively monitoring the situation. For updates from Cloudflare, please refer to their status page at https://www.cloudflarestatus.com/. Thank you for your patience—we’ll continue to keep this incident updated.
Posted Dec 19, 2025 - 12:39 EST
This incident affected: Third Party Services (Cloudflare API).