schools-with-custom-domains-are-down

Incident Report for Teachable

Resolved

Our team has resolved an issue resulting in widespread platform outages that lasted 30 minutes. During that timeframe, users would have had encountered errors accessing pages, and requests to our systems failed. We apologize for the disruption and thank you for your patience.
Posted Jun 24, 2025 - 16:28 EDT

Investigating

Our team has identified an issue resulting in widespread platform outages, especially on schools with custom domains. We understand the critical urgency of resolving this issue and we apologize for the inconvenience. Thank you for your patience, and please check back here for an update shortly.
Posted Jun 24, 2025 - 16:00 EDT